I found the FTOS concept of a “default VLAN” confusing and inconsistent. Begin with the first sentence under the “Default VLAN” heading on page 918 in the user manual:

When you configure interfaces for Layer 2 mode, they are automatically placed in the Default VLAN as untagged interfaces.

This sounds promising. It looks like all interfaces will belong to this VLAN by default, but could be removed if needed. This is incorrect.

The next sentence is the kicker:

Only untagged interfaces can belong to the Default VLAN.

As far as I can tell, from practical experience, this means you can’t create a hybrid port with tagged and untagged traffic using the default VLAN ID configured in FTOS. Rather than spend further time on it, I found it easier to switch the “default VLAN ID” to an unused VLAN ID, and then configure VLAN ID 1 like a normal VLAN.

Disabling the default VLAN

Dell(conf)#default vlan-id 4094
Dell(conf)#do show vlan

Codes: * - Default VLAN, G - GVRP VLANs, R - Remote Port Mirroring VLANs, P - Primary, C - Community, I - Isolated
       O - Openflow, Vx - Vxlan
Q: U - Untagged, T - Tagged
   x - Dot1x untagged, X - Dot1x tagged
   o - OpenFlow untagged, O - OpenFlow tagged
   G - GVRP tagged, M - Vlan-stack, H - VSN tagged
   i - Internal untagged, I - Internal tagged, v - VLT untagged, V - VLT tagged

    NUM    Status    Description                     Q Ports
    <snip>
*   4094   Inactive

Configuring VLAN ID 1

Dell(conf)#interface vlan 1
Dell(conf-if-vl-1)#untagged te 0/44-47
Dell(conf-if-vl-1)#no shut
Dell(conf-if-vl-1)#show config
!
interface Vlan 1
 no ip address
 untagged TenGigabitEthernet 0/44-47
 no shutdown

If you received a “Error: Tagged flag mis-match” in the prior section, you may need to reconfigure the port in hybrid mode.

Switching a port into hybrid mode

If the interfaces are already members of a VLAN, you’ll need to remove the tagged configuration for those ports and otherwise revert them to the factory defaults (e.g., default interface te 0/44); otherwise, you may receive a “Error: Port is in Layer-2 mode” error.

Once the configuration has been reverted on the requisite ports, run portmode hybrid as the first command when configuring the interface or range:

Dell(conf)#interface range tengigabitethernet 0/44-47
Dell(conf-if-range-te-0/44-47)#portmode hybrid
Dell(conf-if-range-te-0/44-47)#switchport
Dell(conf-if-range-te-0/44-47)#no shut
Dell(conf-if-range-te-0/44-47)#show config
!
interface TenGigabitEthernet 0/44
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface TenGigabitEthernet 0/45
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface TenGigabitEthernet 0/46
 no ip address
 portmode hybrid
 switchport
 no shutdown
!
interface TenGigabitEthernet 0/47
 no ip address
 portmode hybrid
 switchport
 no shutdown